Welcome close

INFO : Browser Plugins for eWebEditPro and WebImageFX

Applies To:
All Editors
Summary:
Newer Mozilla-based browsers do not support older versions of eWebeditPro. eWebEditPro appears as if it is not installed on the client. It shows either a blank area or a textarea field.
Symptoms:
  • Editor appears as a white box on the browser
Causes:
  • Outdated eWebEditPro core JavaScript file on the server, and missing Esker ActiveX Plugin on clients. 
Solutions:
  • Update eWebEditPro core JavaScript file on server

  • Install Esker ActiveX Plugin on clients

Step 1 - Update eWebEditPro core JavaScript file on the server

1. On the server, back up your eWebEditPro core JavaScript file (ewep.js), located in the ewebeditpro root folder. (For CMS products, it is located in the workarea/ewebeditpro folder.)

2. Review the table below. In the "Files needed" cell that corresponds to your eWebEditPro version, click the link and save the file to your machine. Once downloaded, extract the ewep.js file to your ewebeditpro folder in the server.

 eWebEditPro Version  Build Number  Files needed
 V2  2,6,0,7  eWebEditPro 2,6,0,7 
 V3  3,2,0,5  eWebEditPro 3,2,0,5 
 V4  4,4,0,28  eWebEditPro 4,4,0,28 
 V4 (with WebImageFX v1.2)  4,4,0,28  eWebEditPro 4,4,0,28 with WebImageFX 1,2,0,16 
 V5  5,1,0,43  eWebEditPro 5,1,0,43 
 V5 (with WebImageFX v1.2)  5,1,0,43  eWebEditPro 5,1,0,43 with WebImageFX 1,2,0,18 
     

If the build number in the table does not match your eWebEditPro build and you do not want to upgrade the client editor to that build, save the matching major version. For example, your editor version is "3,1,0,11", and you save the  files needed for "3,2,0,5". Next, open ewep.js in the zip in a text editing application such as Notepad, search for the build number, and replace it with your editor version.  To continue the above example, find "3,2,0,5" and replace it with "3,1,0,11". This is the "cVersion" variable in the JavaScript that you are changing and the value of the cVersion is a comma(,) delimited list.

Step 2 - Install Esker ActiveX Plugin

Depending on which version of Netscape, Mozilla, or Firefox the client machines are using, save the Esker plugin from the zip to the browser plugin folder(s).

Netscape
version 
Mozilla
version
Firefox
version
 Esker ActiveX Plugin needed

 v4.x

 

 

 v4.5 (npeskp32.dll in v45 folder)

 v6.0

 

 

 v6.4 (np6esk32.dll in v64 folder)

 v6.1

 

 

 v6.5 (np6esk32.dll in v65 folder)

 v6.2

 

 

 v6.6 (np6esk32.dll in v66 folder)

 v7.0

 v1.0

 

 v7 (np7esk32.dll in v70 folder)

 v7.1

 v1.4

 

 v7.2 (np71esk32.dll in v72 folder)

 v7.2

 v1.7

 v0.9, v1.0

 v7.9 (np72esk32.dll in v79 folder)

 v8.1

 

 

 v7.92 (np792esk32.dll in v792 folder)

 

 v1.8

 v1.5, v2.0

 v7.93 (np793esk32.dll in v793 folder)

 

 

v3.0

 v7.96 (np796esk32.dll in v796 folder)
       

The Netscape browser plugin folder is usually at C:\Program Files\Netscape\Netscape Browser\plugins.

The Mozilla browser plugin folder is usually at C:\Program Files\mozilla.org\plugins.

The FireFox browser plugin folder is usually at C:\Program Files\Mozilla Firefox\plugins.

If you are using eWebEditPro v4.4+, the Ektron plugins, NPeWebEditPro.dll and/or NPWebImageFX.dll, must also reside in the browser plugin folder.  These files are usually installed to plugin folders by ewebeditproclient.exe or webimagefxclient.exe.  If they are missing from the plugin folder, extract them from the zip file. 

When the installation is complete, restart the browser to use the plugins.

More Resources:
http://groups.yahoo.com/group/esker-activex-plugin/ 
SEARCH : searchSite
This SectionSite Wide

Ektron Knowledge Base

The Knowledge Base has thousands of articles describing open and past issues and providing answers to frequently asked questions.

Hover the mouse over to the side bar to open a side menu and expend a node for a list of articles.

INFO:Browser Plugins for eWebEditPro and WebImageFX

Applies To:
All Editors
Summary:
Newer Mozilla-based browsers do not support older versions of eWebeditPro. eWebEditPro appears as if it is not installed on the client. It shows either a blank area or a textarea field.
Symptoms:
  • Editor appears as a white box on the browser
Causes:
  • Outdated eWebEditPro core JavaScript file on the server, and missing Esker ActiveX Plugin on clients. 
Solutions:
  • Update eWebEditPro core JavaScript file on server

  • Install Esker ActiveX Plugin on clients

Step 1 - Update eWebEditPro core JavaScript file on the server

1. On the server, back up your eWebEditPro core JavaScript file (ewep.js), located in the ewebeditpro root folder. (For CMS products, it is located in the workarea/ewebeditpro folder.)

2. Review the table below. In the "Files needed" cell that corresponds to your eWebEditPro version, click the link and save the file to your machine. Once downloaded, extract the ewep.js file to your ewebeditpro folder in the server.

 eWebEditPro Version  Build Number  Files needed
 V2  2,6,0,7  eWebEditPro 2,6,0,7 
 V3  3,2,0,5  eWebEditPro 3,2,0,5 
 V4  4,4,0,28  eWebEditPro 4,4,0,28 
 V4 (with WebImageFX v1.2)  4,4,0,28  eWebEditPro 4,4,0,28 with WebImageFX 1,2,0,16 
 V5  5,1,0,43  eWebEditPro 5,1,0,43 
 V5 (with WebImageFX v1.2)  5,1,0,43  eWebEditPro 5,1,0,43 with WebImageFX 1,2,0,18 
     

If the build number in the table does not match your eWebEditPro build and you do not want to upgrade the client editor to that build, save the matching major version. For example, your editor version is "3,1,0,11", and you save the  files needed for "3,2,0,5". Next, open ewep.js in the zip in a text editing application such as Notepad, search for the build number, and replace it with your editor version.  To continue the above example, find "3,2,0,5" and replace it with "3,1,0,11". This is the "cVersion" variable in the JavaScript that you are changing and the value of the cVersion is a comma(,) delimited list.

Step 2 - Install Esker ActiveX Plugin

Depending on which version of Netscape, Mozilla, or Firefox the client machines are using, save the Esker plugin from the zip to the browser plugin folder(s).

Netscape
version 
Mozilla
version
Firefox
version
 Esker ActiveX Plugin needed

 v4.x

 

 

 v4.5 (npeskp32.dll in v45 folder)

 v6.0

 

 

 v6.4 (np6esk32.dll in v64 folder)

 v6.1

 

 

 v6.5 (np6esk32.dll in v65 folder)

 v6.2

 

 

 v6.6 (np6esk32.dll in v66 folder)

 v7.0

 v1.0

 

 v7 (np7esk32.dll in v70 folder)

 v7.1

 v1.4

 

 v7.2 (np71esk32.dll in v72 folder)

 v7.2

 v1.7

 v0.9, v1.0

 v7.9 (np72esk32.dll in v79 folder)

 v8.1

 

 

 v7.92 (np792esk32.dll in v792 folder)

 

 v1.8

 v1.5, v2.0

 v7.93 (np793esk32.dll in v793 folder)

 

 

v3.0

 v7.96 (np796esk32.dll in v796 folder)
       

The Netscape browser plugin folder is usually at C:\Program Files\Netscape\Netscape Browser\plugins.

The Mozilla browser plugin folder is usually at C:\Program Files\mozilla.org\plugins.

The FireFox browser plugin folder is usually at C:\Program Files\Mozilla Firefox\plugins.

If you are using eWebEditPro v4.4+, the Ektron plugins, NPeWebEditPro.dll and/or NPWebImageFX.dll, must also reside in the browser plugin folder.  These files are usually installed to plugin folders by ewebeditproclient.exe or webimagefxclient.exe.  If they are missing from the plugin folder, extract them from the zip file. 

When the installation is complete, restart the browser to use the plugins.

More Resources:
http://groups.yahoo.com/group/esker-activex-plugin/